Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Wheel problem
#11

They need to revamp their final inspection process. I also hear employees do not rate it as a good place to work, that being no excuse to not perform your job correctly.
Reply
#12

I just heard from my service department. The wheel bearing was leaking grease...major risk for seizing. The other side had tear in CV boot. I am really angry with the poor quality VH is putting out
Reply
#13

Could be time for a class-action lawsuit.
Reply
#14

Hello Indy,

Seems like you have BOTH problems.

The cv boot failure AND the wheel bearing issue.

There have been recalls on the cv boot split.
My dealer (Chicago and Fla) says my 2019 Speedster isn’t one of them.  But, my boots are currently fine anyway.

The wheel bearing problem that you have pictured and the young lady in the video seems to have had IS  the issue for my left (drivers side) front wheel.

I caught it early and almost as soon as it occurred thanks to this forum and pre-ride checking of the vehicle.  I was preparing to drive it to my dealer when I found the leak from the center of the wheel-axle down the inside of wheel and onto the rim.  Nothing on or near the boot.  Boot was like new and intact.  Was taking it in for the suspension “bumper” install recall.

I washed the cart and the wheel rims before I had it flatbedded to dealer in Chicago; they checked boots; no problem of course ( I had done that); they “didn’t see” an issue.  They drove it a couple times and reported no issue.  I insisted that the liquified grease was coming from the axle at the wheel junction and anyway there was residual grease visible there if they got a bright light and looked.

The technician that I spoke to directly, agreed to put it up on lift again and look one last time......

Parts are on order from Utah.  I would have specified overnight delivery if I had been asked but .... already done.  So now I wait, like you are doing I suppose.  The tech said he checked the passenger side front and it is good.

As this is my first issue in 5000 miles, I’m not discouraged at this point.  I sure would like to get it back next week, but that will depend on Utah getting parts out to Chicago (and packaging it so it isn’t damaged in shipping) so iMotorsports can repair and replace.

So far I am under warranty but that is ending soon.  I may split for an extended warranty from the dealer.....

Or I may go shopping for a 66 Shelby Cobra and call it a day.  Smile

BTW, if you are from Indianapolis and we both get our carts running again, I’d be interested in having a meet in the fall.  I have relatives in the Indy area.

Best wishes and good luck with the “fix”

Paul AB

CHICAGO
Reply
#15

I am lucky to have a good service department - knowing what I know about VH, I would not own this thing without a local dealer to work with.

Both wheel bearings needed to be replaced, both axles, and both CV boots (4700 miles).  The service guys are professional and when i ask about VH they just shake their heads wondering what the heck is going on in Utah.  I love driving this and there is not an alternative in this category that I would switch to (morgan is out of the question) so I will continue to deal with this.  What is the warranty period....2 years?

PaulAB - happy to meet up when you are in Indy.  The good news I guess is that the new dealer seems to be selling them faster than they can get them in - they don't sit on the floor very long.

ps.  tried to insert a picture of the old wheel bearing but the only option is to put in a URL
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)